about summary refs log tree commit diff
path: root/hosts/profiles/nas.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/profiles/nas.nix')
-rw-r--r--hosts/profiles/nas.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/hosts/profiles/nas.nix b/hosts/profiles/nas.nix
index dcc73e2..aaeee75 100644
--- a/hosts/profiles/nas.nix
+++ b/hosts/profiles/nas.nix
@@ -9,7 +9,6 @@
     ../common/server/unifi.nix
     ../common/server/gitea.nix
     ../common/server/rclone.nix
-    ../common/server/navidrome.nix
   ];
 
   users.groups.nas.gid = 5000;
@@ -19,9 +18,15 @@
     isSystemUser = true;
   };
 
-  my.services.samba = {
-    enable = true;
-    publicShares = [ "/data/fast/music" "/data/fast/videos" ];
+  my.services = {
+    samba = {
+      enable = true;
+      publicShares = [ "/data/fast/music" "/data/fast/videos" ];
+    };
+    navidrome = {
+      enable = true;
+      musicFolder = "/data/fast/music";
+    };
   };
 
   services.restic.backups = {