about summary refs log tree commit diff
path: root/hosts/commons/desktop/sound.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/commons/desktop/sound.nix')
-rw-r--r--hosts/commons/desktop/sound.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/hosts/commons/desktop/sound.nix b/hosts/commons/desktop/sound.nix
new file mode 100644
index 0000000..95c7c75
--- /dev/null
+++ b/hosts/commons/desktop/sound.nix
@@ -0,0 +1,20 @@
+{pkgs, config, lib, ...}:
+
+{
+  sound.enable = true;
+
+  environment.systemPackages = with pkgs; [
+    # We install it to get access to pactl. It isn't enabled or run as a service.
+    pulseaudio
+  ];
+
+  services.pipewire = {
+    enable = true;
+    # Compatibility shims, adjust according to your needs
+    alsa.enable = true;
+    alsa.support32Bit = true;
+    pulse.enable = true;
+    jack.enable = true;
+  };
+  hardware.pulseaudio.enable = false;
+}