about summary refs log tree commit diff
path: root/hosts/commons/desktop/sound.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-12 13:47:59 -0800
commit8ed3dfc9ebc52a50c3e6d4623204847822944422 (patch)
tree5ecaf4eb3719f6d60e471775cd6de5da7cb78b46 /hosts/commons/desktop/sound.nix
parentconfigs: move personal configuration with user (diff)
downloadworld-8ed3dfc9ebc52a50c3e6d4623204847822944422.tar.gz
move configurations and modules around
Sorry, this is a mess, hopefully the last one.
Diffstat (limited to 'hosts/commons/desktop/sound.nix')
-rw-r--r--hosts/commons/desktop/sound.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/hosts/commons/desktop/sound.nix b/hosts/commons/desktop/sound.nix
new file mode 100644
index 0000000..95c7c75
--- /dev/null
+++ b/hosts/commons/desktop/sound.nix
@@ -0,0 +1,20 @@
+{pkgs, config, lib, ...}:
+
+{
+  sound.enable = true;
+
+  environment.systemPackages = with pkgs; [
+    # We install it to get access to pactl. It isn't enabled or run as a service.
+    pulseaudio
+  ];
+
+  services.pipewire = {
+    enable = true;
+    # Compatibility shims, adjust according to your needs
+    alsa.enable = true;
+    alsa.support32Bit = true;
+    pulse.enable = true;
+    jack.enable = true;
+  };
+  hardware.pulseaudio.enable = false;
+}