about summary refs log tree commit diff
path: root/hosts/common/system/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/system/users.nix')
-rw-r--r--hosts/common/system/users.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/hosts/common/system/users.nix b/hosts/common/system/users.nix
deleted file mode 100644
index 7d847f3..0000000
--- a/hosts/common/system/users.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-{
-  # Users are managed through this configuration. If a user is added
-  # manually, it will be removed on system activation.
-  users.mutableUsers = false;
-
-  users.groups.fcuny = { gid = 1000; };
-  users.users.fcuny = {
-    isNormalUser = true;
-    uid = 1000;
-    group = "fcuny";
-    home = "/home/fcuny";
-    shell = pkgs.fish;
-    extraGroups = [ "users" "wheel" "docker" ];
-    hashedPassword =
-      "$6$i.z1brxtb44JAEco$fDD2Izl.zRR9vBCB2VBKPScChGw38EEl7QEiBTJ/EwgP3oSL0X3ZHq0PJ.RtqzBsWTPUjl4F3MKOBMhnaAPr6.";
-    openssh.authorizedKeys.keys = [
-      # aptos
-      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIdlm/qoR/dnMjZhVSTtqFzkgN3Yf9eQ3pgKMiipg+dl"
-      # work
-      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINSWhXmnUplM+xltD0sYiJ6AsjkwHvbjTYLA7GHXHja9"
-    ];
-  };
-
-  users.users.root = {
-    hashedPassword = null;
-    openssh.authorizedKeys.keys =
-      config.users.users.fcuny.openssh.authorizedKeys.keys;
-  };
-}