about summary refs log tree commit diff
path: root/hosts/common/system/software.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/system/software.nix')
-rw-r--r--hosts/common/system/software.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/hosts/common/system/software.nix b/hosts/common/system/software.nix
index fa919ae..1f746fb 100644
--- a/hosts/common/system/software.nix
+++ b/hosts/common/system/software.nix
@@ -1,14 +1,18 @@
 {pkgs, config, lib, ...}:
 
-{
+with lib;
+let linuxpkgs = config.boot.kernelPackages;
+in {
   environment.systemPackages = with pkgs; [
     curl
     dmidecode
+    flameGraph
     git
     htop
     hwdata
     iftop
     iptraf-ng
+    linuxpkgs.perf
     lm_sensors
     lsb-release
     mg
@@ -16,6 +20,7 @@
     openssl
     parted
     pciutils
+    perf-tools
     rsync
     strace
     tcpdump
@@ -26,4 +31,6 @@
     vim
     wget
   ];
+
+  programs.bcc.enable = true;
 }