about summary refs log tree commit diff
path: root/hosts/common/system/software.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/system/software.nix')
-rw-r--r--hosts/common/system/software.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/hosts/common/system/software.nix b/hosts/common/system/software.nix
deleted file mode 100644
index e872679..0000000
--- a/hosts/common/system/software.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ pkgs, config, lib, ... }:
-
-with lib;
-
-let linuxpkgs = config.boot.kernelPackages;
-in {
-  environment.systemPackages = with pkgs; [
-    binutils
-    cacert
-    curl
-    dmidecode
-    ethtool
-    flameGraph
-    git
-    htop
-    hwdata
-    iftop
-    iptraf-ng
-    linuxpkgs.perf
-    lm_sensors
-    lsb-release
-    lsof
-    man-pages
-    mg
-    mtr
-    openssl
-    openssl
-    parted
-    pciutils
-    perf-tools
-    powertop
-    rsync
-    sqlite
-    strace
-    tcpdump
-    tmux
-    traceroute
-    unzip
-    usbutils
-    vim
-    wget
-    wireguard
-    zsh
-  ];
-
-  programs.bcc.enable = true;
-}