about summary refs log tree commit diff
path: root/hosts/common/system/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/system/nix.nix')
-rw-r--r--hosts/common/system/nix.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/common/system/nix.nix b/hosts/common/system/nix.nix
new file mode 100644
index 0000000..48379a4
--- /dev/null
+++ b/hosts/common/system/nix.nix
@@ -0,0 +1,18 @@
+{ lib, pkgs, ... }:
+
+{
+  # Enable flakes and new 'nix' command
+  nix = {
+    package = pkgs.nixFlakes;
+    extraOptions = ''
+      experimental-features = nix-command flakes
+    '';
+    autoOptimiseStore = true;
+    trustedUsers = [ "root" "@wheel" ];
+
+    gc = {
+      automatic = true;
+      options = "--delete-older-than 14d";
+    };
+  };
+}