about summary refs log tree commit diff
path: root/hosts/common/macos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/macos.nix')
-rw-r--r--hosts/common/macos.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/common/macos.nix b/hosts/common/macos.nix
new file mode 100644
index 0000000..edc57a0
--- /dev/null
+++ b/hosts/common/macos.nix
@@ -0,0 +1,23 @@
+{ ... }: {
+  system.defaults.dock.autohide = true;
+  system.defaults.dock.orientation = "left";
+  system.defaults.dock.showhidden = false;
+  system.defaults.dock.show-recents = false;
+  # don’t rearrange spaces based on the most recent use
+  system.defaults.dock.mru-spaces = false;
+  system.defaults.finder.AppleShowAllExtensions = true;
+  system.defaults.screencapture.location = "~/Documents/screenshots";
+
+  system.keyboard = {
+    enableKeyMapping = true;
+    remapCapsLockToControl = true;
+  };
+
+  system.defaults.CustomUserPreferences = {
+    "com.apple.desktopservices" = {
+      # Avoid creating .DS_Store files on network or USB volumes
+      DSDontWriteNetworkStores = true;
+      DSDontWriteUSBStores = true;
+    };
+  };
+}