about summary refs log tree commit diff
path: root/hosts/carmel/services.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/services.nix')
-rw-r--r--hosts/carmel/services.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/hosts/carmel/services.nix b/hosts/carmel/services.nix
index 7facf4a..d469618 100644
--- a/hosts/carmel/services.nix
+++ b/hosts/carmel/services.nix
@@ -1,4 +1,4 @@
-{ config, ... }: {
+{ config, pkgs, ... }: {
   my.services = {
     metrics-exporter = { enable = true; };
     avahi = {
@@ -26,6 +26,9 @@
       local=/home/
       no-resolv
 
+      dhcp-script=${pkgs.tools.dnsmasq-to-html}/bin/dnsmasq-leases-html
+      script-on-renewal
+
       dhcp-authoritative
 
       interface=mgmt0