about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/default.nix')
-rw-r--r--hosts/carmel/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
index 83d6317..cbad04d 100644
--- a/hosts/carmel/default.nix
+++ b/hosts/carmel/default.nix
@@ -1,8 +1,13 @@
-{ ... }:
+{ self, ... }:
 
 {
-  imports =
-    [ ./hardware.nix ./boot.nix ./networking.nix ./services.nix ];
+  imports = [
+    ./hardware.nix
+    ./boot.nix
+    ./networking.nix
+    ./services.nix
+    "${self}/profiles/server.nix"
+  ];
 
   # This value determines the NixOS release from which the default
   # settings for stateful data, like file locations and database versions