about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-02 07:51:56 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-02 07:51:56 -0700
commitb1ffabc10483067a2a402a945821ead78bfa4f84 (patch)
treed5ea8202a992c28793781a73769ed8ae05af1c73 /hosts/carmel/default.nix
parentprofiles/workstation: consolidate sound related configurations (diff)
downloadworld-b1ffabc10483067a2a402a945821ead78bfa4f84.tar.gz
profiles: create default and server
The NAS and the router are "servers", and we create a base profile for
them.

We add a default profile that will set things that are common to all my
hosts, and we start with the locales.

Update tahoe/carmel to use the server profile.
Diffstat (limited to 'hosts/carmel/default.nix')
-rw-r--r--hosts/carmel/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
index 83d6317..cbad04d 100644
--- a/hosts/carmel/default.nix
+++ b/hosts/carmel/default.nix
@@ -1,8 +1,13 @@
-{ ... }:
+{ self, ... }:
 
 {
-  imports =
-    [ ./hardware.nix ./boot.nix ./networking.nix ./services.nix ];
+  imports = [
+    ./hardware.nix
+    ./boot.nix
+    ./networking.nix
+    ./services.nix
+    "${self}/profiles/server.nix"
+  ];
 
   # This value determines the NixOS release from which the default
   # settings for stateful data, like file locations and database versions