about summary refs log tree commit diff
path: root/home/wm/wofi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/wm/wofi/default.nix')
-rw-r--r--home/wm/wofi/default.nix54
1 files changed, 2 insertions, 52 deletions
diff --git a/home/wm/wofi/default.nix b/home/wm/wofi/default.nix
index 9ccb4be..f1e1663 100644
--- a/home/wm/wofi/default.nix
+++ b/home/wm/wofi/default.nix
@@ -3,57 +3,7 @@ let isEnabled = config.my.home.wm.windowManager == "sway";
 in {
   config = lib.mkIf isEnabled {
     home.packages = with pkgs; [ wofi ];
-    xdg.configFile."wofi/config".text = ''
-      allow_images=true
-      image_size=20px
-      drun-display_generic=true
-      dynamic_lines=true
-    '';
-
-    xdg.configFile."wofi/style.css".text = ''
-      *{
-        font-family: monospace;
-      }
-
-      window {
-        color: #5E81AC;
-        background-color: rgba(27, 27, 28, 0.92);
-        border: 2px solid #75d5ff;
-      }
-
-      #input {
-        margin: 10px 0px;
-        border-radius: 0px;
-        border: none;
-        background: transparent;
-        color: white;
-      }
-
-      #inner-box {
-        background-color: transparent;
-      }
-
-      #outer-box {
-        margin: 0px;
-        padding:5px;
-        background-color: transparent;
-      }
-
-      #text {
-        padding: 5px;
-        color: white;
-      }
-
-      #entry:selected {
-        color: #75d5ff;
-        background-color: transparent;
-        border: 0px;
-      }
-
-      #text:selected {
-        color: #75d5ff;
-        background-color: transparent;
-      }
-    '';
+    xdg.configFile."wofi/config".source = ./config;
+    xdg.configFile."wofi/style.css".source = ./style.css;
   };
 }