about summary refs log tree commit diff
path: root/home/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/ssh.nix')
-rw-r--r--home/ssh.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/home/ssh.nix b/home/ssh.nix
new file mode 100644
index 0000000..47aee8a
--- /dev/null
+++ b/home/ssh.nix
@@ -0,0 +1,21 @@
+{ ... }:
+{
+  programs.ssh = {
+    enable = true;
+    forwardAgent = true;
+    serverAliveInterval = 60;
+    controlMaster = "auto";
+    controlPersist = "30m";
+    extraConfig = ''
+      IdentityAgent "~/Library/Group Containers/2BUA8C4S2C.com.1password/t/agent.sock"
+    '';
+    matchBlocks = {
+      "github.com" = {
+        hostname = "github.com";
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+    };
+  };
+}