about summary refs log tree commit diff
path: root/home/shell/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/shell/default.nix')
-rw-r--r--home/shell/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/home/shell/default.nix b/home/shell/default.nix
new file mode 100644
index 0000000..35a6275
--- /dev/null
+++ b/home/shell/default.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+let cfg = config.my.home.shell;
+in
+{
+  options.my.home.shell = {
+    name = mkOption {
+      default = "zsh";
+      type = types.enum [ "fish" "zsh" ];
+      example = "zsh";
+    };
+  };
+
+  imports = [ ./fish ./zsh ];
+}