about summary refs log tree commit diff
path: root/home/python/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/python/default.nix')
-rw-r--r--home/python/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/home/python/default.nix b/home/python/default.nix
index 9e72569..cd866be 100644
--- a/home/python/default.nix
+++ b/home/python/default.nix
@@ -1,10 +1,16 @@
 { config, pkgs, lib, ... }:
-let cfg = config.my.home.python;
+let
+  cfg = config.my.home.python;
+  pythonEnv = pkgs.python310.withPackages (p: with p; [
+    requests
+    black
+    isort
+  ]);
 in
 {
   options.my.home.python = with lib; {
     enable = mkEnableOption "python configuration";
   };
 
-  config.home.packages = with pkgs; lib.mkIf cfg.enable ([ python310 ]);
+  config.home.packages = with pkgs.python310Packages; lib.mkIf cfg.enable ([ pythonEnv ]);
 }