about summary refs log tree commit diff
path: root/home/profiles/tmux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/tmux.nix')
-rw-r--r--home/profiles/tmux.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home/profiles/tmux.nix b/home/profiles/tmux.nix
new file mode 100644
index 0000000..22f8683
--- /dev/null
+++ b/home/profiles/tmux.nix
@@ -0,0 +1,20 @@
+{ ... }:
+{
+  programs.tmux = {
+    enable = true;
+
+    terminal = "xterm-256color";
+    escapeTime = 0;
+    aggressiveResize = true;
+    baseIndex = 1;
+    shortcut = "z";
+    clock24 = true;
+    historyLimit = 50000; # Bigger buffer
+
+    extraConfig = ''
+      setw -g mouse on
+
+      set-option -g renumber-windows on
+    '';
+  };
+}