about summary refs log tree commit diff
path: root/home/profiles/tmux.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-07-28 19:21:33 -0700
committerFranck Cuny <franck@fcuny.net>2023-07-28 19:21:33 -0700
commit5f2b01db3fc7fc78d42aa07080b551f71d73ee6a (patch)
treeca3dac720e239f0f6d27772bc171a6e0018f5eb8 /home/profiles/tmux.nix
parentadd fonts specifically (diff)
downloadworld-5f2b01db3fc7fc78d42aa07080b551f71d73ee6a.tar.gz
switching back to alacritty + tmux
kitty is not clicking for me. I still prefer tmux.
Diffstat (limited to 'home/profiles/tmux.nix')
-rw-r--r--home/profiles/tmux.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home/profiles/tmux.nix b/home/profiles/tmux.nix
new file mode 100644
index 0000000..22f8683
--- /dev/null
+++ b/home/profiles/tmux.nix
@@ -0,0 +1,20 @@
+{ ... }:
+{
+  programs.tmux = {
+    enable = true;
+
+    terminal = "xterm-256color";
+    escapeTime = 0;
+    aggressiveResize = true;
+    baseIndex = 1;
+    shortcut = "z";
+    clock24 = true;
+    historyLimit = 50000; # Bigger buffer
+
+    extraConfig = ''
+      setw -g mouse on
+
+      set-option -g renumber-windows on
+    '';
+  };
+}