about summary refs log tree commit diff
path: root/home/profiles/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/sway.nix')
-rw-r--r--home/profiles/sway.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/home/profiles/sway.nix b/home/profiles/sway.nix
index dc3999c..193ecd5 100644
--- a/home/profiles/sway.nix
+++ b/home/profiles/sway.nix
@@ -1,6 +1,12 @@
 { config, lib, pkgs, ... }:
 let
   modifier = "Mod4"; # `Super` key
+  fonts = {
+    names = [ "Roboto" "Font Awesome 5 Free" "Font Awesome 5 Brands" "Arial" "sans-serif" ];
+    style = "Bold";
+    size = 10.0;
+  };
+
 in
 {
   imports = [
@@ -59,15 +65,11 @@ in
     # dbus-update-activation-environment
     systemdIntegration = true;
     config = {
+      inherit fonts modifier;
       # FIXME: this should be a variable
       terminal = "kitty";
-      modifier = modifier;
       menu = ''${pkgs.wofi}/bin/wofi -S drun -p "app:" -L 10'';
       bars = [ ];
-      fonts = {
-        names = [ "Source Code Pro" ];
-        size = 10.0;
-      };
       keybindings = lib.mkOptionDefault {
         # control the volume
         "XF86AudioRaiseVolume" =
@@ -139,10 +141,11 @@ in
   };
 
   xdg.configFile."swaylock/config".source = pkgs.writeText "config" ''
-    color=2E3440
     daemonize
-    indicator-caps-lock
     hide-keyboard-layout
+    indicator-caps-lock
+    color=2E3440
+    font=Roboto
   '';
 
   services.swayidle = {