about summary refs log tree commit diff
path: root/home/profiles/dev.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/dev.nix')
-rw-r--r--home/profiles/dev.nix16
1 files changed, 3 insertions, 13 deletions
diff --git a/home/profiles/dev.nix b/home/profiles/dev.nix
index e2806ab..dd9409d 100644
--- a/home/profiles/dev.nix
+++ b/home/profiles/dev.nix
@@ -1,13 +1,5 @@
 { pkgs, config, ... }:
 let
-  ruststable = (pkgs.rust-bin.stable.latest.default.override {
-    extensions = [
-      "rust-src"
-      "rust-analyzer-preview"
-      "rust-analysis"
-      "rustfmt-preview"
-    ];
-  });
   pythonEnv = pkgs.python3.withPackages (p: with p; [
     black
     click
@@ -25,20 +17,19 @@ in
     enable = true;
     goPath = ".local/share/pkg.go";
     goBin = ".local/bin.go";
-    goPrivate = [ "git.fcuny.net" "golang.fcuny.net" ];
-    package = pkgs.go_1_18;
+    package = pkgs.go_1_20;
   };
 
   home.packages = with pkgs; [
     go-tools
     pythonEnv
     google-cloud-sdk
-    ruststable
+    golangci-lint
+    gopls
   ];
 
   home.sessionPath = [
     config.home.sessionVariables.GOBIN
-    "$CARGO_HOME/bin"
   ];
 
   home.sessionVariables = with config.xdg; {
@@ -47,6 +38,5 @@ in
     PYLINTHOME = "${cacheHome}/pylint";
     PYTHON_EGG_CACHE = "${cacheHome}/python-eggs";
     MYPY_CACHE_DIR = "${cacheHome}/mypy";
-    CARGO_HOME = "${dataHome}/cargo";
   };
 }