about summary refs log tree commit diff
path: root/home/feh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/feh/default.nix')
-rw-r--r--home/feh/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/home/feh/default.nix b/home/feh/default.nix
new file mode 100644
index 0000000..0032252
--- /dev/null
+++ b/home/feh/default.nix
@@ -0,0 +1,8 @@
+{ config, lib, ... }:
+let cfg = config.my.home.feh;
+in {
+  options.my.home.feh = with lib; {
+    enable = mkEnableOption "feh configuration";
+  };
+  config.programs.feh = lib.mkIf cfg.enable { enable = true; };
+}