about summary refs log tree commit diff
path: root/flake/hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/hosts.nix')
-rw-r--r--flake/hosts.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/flake/hosts.nix b/flake/hosts.nix
index 9ec9d1b..7fc0612 100644
--- a/flake/hosts.nix
+++ b/flake/hosts.nix
@@ -1,12 +1,21 @@
 { inputs, ... }:
 let
-  inherit (inputs) nixpkgs darwin home-manager;
+  inherit (inputs) nixpkgs darwin home-manager firefox-darwin nur;
   inherit (nixpkgs.lib) mkMerge;
 
   mkDarwinConfig = system: path:
     darwin.lib.darwinSystem {
       inherit system;
-      modules = [ home-manager.darwinModule path ];
+      modules = [
+        home-manager.darwinModule
+        path
+        {
+          nixpkgs.overlays = [
+            firefox-darwin.overlay
+            nur.overlay
+          ];
+        }
+      ];
       specialArgs = { inherit inputs; };
     };
 in