about summary refs log tree commit diff
path: root/flake/devshell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/devshell.nix')
-rw-r--r--flake/devshell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake/devshell.nix b/flake/devshell.nix
index 2cdce16..79bb2f9 100644
--- a/flake/devshell.nix
+++ b/flake/devshell.nix
@@ -16,6 +16,8 @@
         packages = with pkgs; [
           (config.treefmt.build.wrapper)
 
+          python3
+
           go_1_21
           gopls
           golangci-lint
@@ -29,6 +31,12 @@
         commands = [
           { package = config.treefmt.build.wrapper; }
           {
+            name = "environment";
+            help = "Print various information from CI";
+            category = "CI";
+            command = "make build-environment";
+          }
+          {
             name = "update";
             help = "Update + Commit the Lock File";
             command = "nix flake update --commit-lock-file";