about summary refs log tree commit diff
path: root/flake/devshell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/devshell.nix')
-rw-r--r--flake/devshell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake/devshell.nix b/flake/devshell.nix
index 886d7c1..2cdce16 100644
--- a/flake/devshell.nix
+++ b/flake/devshell.nix
@@ -46,6 +46,18 @@
             help = "Switch to the current darwin configuration";
             command = "darwin-rebuild switch --flake .#";
           }
+          {
+            name = "build-commands";
+            category = "cmd";
+            help = "Build all the commands";
+            command = "make build-binaries";
+          }
+          {
+            name = "clean";
+            category = "cmd";
+            help = "Delete all the artifacts in bin/";
+            command = "make clean";
+          }
         ];
       };