about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..44f5997
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+{
+  description = "personal NixOS configurations";
+
+  inputs = {
+    # Nixpkgs, NixOS's official repo
+    nixpkgs.url = "github:nixos/nixpkgs/release-21.11";
+  };
+
+  # Output config, or config for NixOS system
+  outputs = { self, nixpkgs, ... }@inputs: {
+    nixosConfigurations = {
+      # desktop
+      carmel = nixpkgs.lib.nixosSystem {
+        system = "x86_64-linux";
+        modules = [
+          ./hosts/carmel/configuration.nix
+        ];
+      };
+    };
+  };
+}