about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix36
1 files changed, 3 insertions, 33 deletions
diff --git a/flake.nix b/flake.nix
index 1bb9b3d..125e214 100644
--- a/flake.nix
+++ b/flake.nix
@@ -43,7 +43,7 @@
   };
 
   # Output config, or config for NixOS system
-  outputs = { self, ... }@inputs:
+  outputs = { self, pre-commit-hooks, ... }@inputs:
     let
       inherit (inputs.futils.lib) eachSystem system;
       mySystems = [ system.x86_64-linux ];
@@ -65,37 +65,7 @@
             users.fcuny = import ./users/fcuny { inherit pkgs; };
           };
 
-          checks = {
-            pre-commit = inputs.pre-commit-hooks.lib.${system}.run {
-              src = ./.;
-
-              hooks = {
-                trailing-whitespace = {
-                  enable = true;
-                  entry =
-                    "${pkgs.python3Packages.pre-commit-hooks}/bin/trailing-whitespace-fixer";
-                  types = [ "text" ];
-                };
-
-                end-of-file-fixer = {
-                  enable = true;
-                  entry =
-                    "${pkgs.python3Packages.pre-commit-hooks}/bin/end-of-file-fixer";
-                  types = [ "text" ];
-                };
-
-                nixpkgs-fmt = { enable = true; };
-
-                terraform-format = { enable = true; };
-
-                shellcheck = {
-                  enable = true;
-                  files = "\\.sh$";
-                  types_or = [ "file" ];
-                };
-              };
-            };
-          };
+          checks = import ./nix/checks.nix { inherit pkgs pre-commit-hooks; };
 
           devShells = {
             default = pkgs.mkShell {
@@ -111,7 +81,7 @@
                 go
                 gopls
               ];
-              inherit (self.checks.${system}.pre-commit) shellHook;
+              inherit (self.checks.${system}.pre-commit-check) shellHook;
             };
           };
         }) // {