about summary refs log tree commit diff
path: root/users/fcuny/trusted/pass.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-08 17:00:00 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-08 17:00:00 -0700
commit364520a9eb1d10f3a8af0b1364ff1498221ddc5a (patch)
tree4e212f28e4467a59d55f4508a7432a8d6dc6ca2e /users/fcuny/trusted/pass.nix
parentcarmel: configure the desktop properly (diff)
downloadworld-364520a9eb1d10f3a8af0b1364ff1498221ddc5a.tar.gz
remove old 'trusted' modules
All of them are now under home/
Diffstat (limited to 'users/fcuny/trusted/pass.nix')
-rw-r--r--users/fcuny/trusted/pass.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/users/fcuny/trusted/pass.nix b/users/fcuny/trusted/pass.nix
deleted file mode 100644
index a552318..0000000
--- a/users/fcuny/trusted/pass.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ pkgs, config, ... }:
-
-{
-  programs.password-store = {
-    enable = true;
-    settings = {
-      PASSWORD_STORE_DIR = "${config.xdg.dataHome}/password-store";
-      PASSWORD_STORE_GENERATED_LENGTH = "30";
-      PASSWORD_STORE_CHARACTER_SET = "a-zA-Z0-9~!@#$%^&*()-_=+[]{};:,.<>?";
-      PASSWORD_STORE_KEY = config.programs.gpg.settings.default-key;
-    };
-  };
-
-  programs.git = {
-    signing = {
-      key = config.programs.gpg.settings.default-key;
-      signByDefault = true;
-    };
-    extraConfig = {
-      credential = {
-        helper = "${pkgs.gitAndTools.pass-git-helper}/bin/pass-git-helper";
-        useHttpPath = true;
-      };
-    };
-  };
-
-  xdg.configFile."pass-git-helper/git-pass-mapping.ini" = {
-    source = ./git-pass-mapping.ini;
-  };
-
-  services.password-store-sync.enable = true;
-
-  # Ensure the password store things are in the systemd session
-  systemd.user.sessionVariables = config.programs.password-store.settings;
-}