about summary refs log tree commit diff
path: root/users/fcuny/resume/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-05-25 18:09:38 -0700
committerFranck Cuny <franck@fcuny.net>2022-05-25 18:09:38 -0700
commit22e7b10377a2a5672d5af6840a9a21e298315cfd (patch)
tree5c294d104b75b7d87bdb907a7f295d9959aefa7c /users/fcuny/resume/flake.nix
parentref(blog): drop the flake configuration (diff)
downloadworld-22e7b10377a2a5672d5af6840a9a21e298315cfd.tar.gz
ref(resume): remove flake.nix
Integrate the resume with the rest of the repository, as I did for the
blog in the previous commit.

Added a script to copy the resume in the static directory of the blog.
Diffstat (limited to 'users/fcuny/resume/flake.nix')
-rw-r--r--users/fcuny/resume/flake.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/users/fcuny/resume/flake.nix b/users/fcuny/resume/flake.nix
deleted file mode 100644
index 35a7d7d..0000000
--- a/users/fcuny/resume/flake.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{
-  description = "Franck Cuny's resume";
-  inputs = {
-    nixpkgs.url = "github:nixos/nixpkgs";
-    flake-utils.url = "github:numtide/flake-utils";
-  };
-
-  outputs = { self, nixpkgs, flake-utils }:
-    flake-utils.lib.eachDefaultSystem (system:
-      let pkgs = nixpkgs.legacyPackages.${system};
-      in {
-        defaultPackage = pkgs.stdenv.mkDerivation {
-          name = "resume";
-          version = self.lastModifiedDate;
-          src = ./.;
-          buildInputs = with pkgs; [ pandoc ];
-          buildPhase = ''
-            pandoc --self-contained --css styles/resume.css --from org --to html --output resume.html resume.org
-          '';
-
-          installPhase = ''
-            mkdir -p $out
-            cp resume.html $out/
-          '';
-        };
-        devShell = pkgs.mkShell { buildInputs = with pkgs; [ git pandoc ]; };
-      });
-}