about summary refs log tree commit diff
path: root/users/fcuny/notes/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-05-25 19:19:24 -0700
committerFranck Cuny <franck@fcuny.net>2022-05-25 19:19:24 -0700
commitc54e3a336fe460db3b4ec156beac452850838555 (patch)
tree7dca8abd153d8d21a3afa6e2bd21687c37d7d77d /users/fcuny/notes/flake.nix
parentref(notes): don't rely on git for modified date (diff)
downloadworld-c54e3a336fe460db3b4ec156beac452850838555.tar.gz
ref(notes): drop flake.nix
There's no need to have a flake.nix for the notes, we can use the same
mechanism as for the blog and resume.

Add a README so I remember how to use this in the future.
Diffstat (limited to 'users/fcuny/notes/flake.nix')
-rw-r--r--users/fcuny/notes/flake.nix46
1 files changed, 0 insertions, 46 deletions
diff --git a/users/fcuny/notes/flake.nix b/users/fcuny/notes/flake.nix
deleted file mode 100644
index 52e25c1..0000000
--- a/users/fcuny/notes/flake.nix
+++ /dev/null
@@ -1,46 +0,0 @@
-{
-  description = "Franck Cuny's notes.";
-
-  inputs = {
-    nixpkgs.url = "github:nixos/nixpkgs";
-    flake-utils.url = "github:numtide/flake-utils";
-  };
-
-  outputs = { self, nixpkgs, flake-utils }:
-    flake-utils.lib.eachDefaultSystem (system:
-      let pkgs = nixpkgs.legacyPackages.${system};
-      in {
-        defaultPackage = with pkgs;
-          stdenv.mkDerivation {
-            pname = "notes.fcuny.net";
-            version = self.lastModifiedDate;
-            src = ./.;
-            buildInputs = [ hugo git ];
-            buildPhase = ''
-              mkdir -p $out
-              hugo --minify --destination $out
-            '';
-            dontInstall = true;
-          };
-
-        defaultApp = pkgs.writers.writeBashBin "run-hugo" ''
-          set -e
-          set -o pipefail
-          export PATH=${pkgs.lib.makeBinPath [ pkgs.hugo pkgs.git ]}
-          hugo server -D
-        '';
-
-        apps = {
-          deploy = pkgs.pkgs.writeShellScriptBin "run-deploy" ''
-            set -euxo pipefail
-            export PATH=${
-              pkgs.lib.makeBinPath [ pkgs.hugo pkgs.git pkgs.jq pkgs.flyctl ]
-            }:$PATH
-            bash ./scripts/deploy.sh
-          '';
-        };
-
-        devShell =
-          pkgs.mkShell { buildInputs = with pkgs; [ hugo flyctl git jq ]; };
-      });
-}