about summary refs log tree commit diff
path: root/users/fcuny/i3.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-08 17:04:52 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-08 17:04:52 -0800
commit3c735e9483f35fe1c1373357facf879e5d449fb2 (patch)
tree64ab3d826e00c4f78e2bb8a9b87fea48bdc55e48 /users/fcuny/i3.nix
parentdesktop: configuration for i3 (diff)
downloadworld-3c735e9483f35fe1c1373357facf879e5d449fb2.tar.gz
i3: move configuration to home-manager
Diffstat (limited to 'users/fcuny/i3.nix')
-rw-r--r--users/fcuny/i3.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/users/fcuny/i3.nix b/users/fcuny/i3.nix
new file mode 100644
index 0000000..3e1a626
--- /dev/null
+++ b/users/fcuny/i3.nix
@@ -0,0 +1,37 @@
+{ config, pkgs, lib, ... }:
+
+{
+  services.xserver = {
+    enable = true;
+    layout = "us";
+    xkbOptions = "eurosign:e";
+    libinput.enable = true;
+
+    desktopManager = {
+      xterm.enable = false;
+    };
+
+    displayManager = {
+      lightdm.enable = true;
+    };
+
+    windowManager = {
+      i3.enable = true;
+    };
+  };
+
+  programs.rofi = {
+    enable = true;
+    theme = "purple";
+
+    extraConfig = {
+      modi = "drun";
+      show-icons = true;
+      icon-theme = "Numix-Square";
+      combi-modi = "window,drun,ssh";
+    };
+  };
+
+  services.gnome.gnome-keyring.enable = true;
+  services.gvfs.enable = true;
+}