about summary refs log tree commit diff
path: root/users/fcuny/desktop/wm/bar.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-25 06:42:48 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-27 13:05:29 -0800
commit713d0476c69c06d6baad9568c0d4def8c1e9fae9 (patch)
treeecea510c6d3524a589a2de406c16a9bfe140dc0b /users/fcuny/desktop/wm/bar.nix
parenthosts: add tahoe, the new NAS (diff)
downloadworld-713d0476c69c06d6baad9568c0d4def8c1e9fae9.tar.gz
sway: re-organize the modules
Rename 'sway' to 'wm' to make it more generic; rename some of the other
modules (e.g. 'wofi' to 'launcher'), for the same reason.
Diffstat (limited to 'users/fcuny/desktop/wm/bar.nix')
-rw-r--r--users/fcuny/desktop/wm/bar.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/users/fcuny/desktop/wm/bar.nix b/users/fcuny/desktop/wm/bar.nix
new file mode 100644
index 0000000..265513d
--- /dev/null
+++ b/users/fcuny/desktop/wm/bar.nix
@@ -0,0 +1,33 @@
+{ pkgs, ... }:
+
+{
+  programs.i3status-rust = {
+    enable = true;
+    bars.default = {
+      settings.theme.name = "plain";
+      icons = "awesome5";
+      blocks = [
+        {
+          block = "net";
+          format = "{ssid} {signal_strength} {ip}";
+          interval = 5;
+        }
+        {
+          block = "battery";
+          interval = 30;
+          format = "{percentage} {time}";
+        }
+        {
+          block = "sound";
+          on_click = "${pkgs.pavucontrol}/bin/pavucontrol";
+        }
+        {
+          block = "time";
+          interval = 1;
+          format = "%b-%d %H:%M:%S";
+          icons_format = "";
+        }
+      ];
+    };
+  };
+}