about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway/wofi.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-13 12:03:41 -0800
commiteebd938fa14164f6f9412e2f61f733a43894dda5 (patch)
tree772f7785a068a3de783b564e46d31934f53e7b02 /users/fcuny/desktop/sway/wofi.nix
parentcli: this is not working (diff)
downloadworld-eebd938fa14164f6f9412e2f61f733a43894dda5.tar.gz
sway: adjust configuration
Create a new directory to have all things related to sway.

Add some extra configuration for wofi.
Diffstat (limited to 'users/fcuny/desktop/sway/wofi.nix')
-rw-r--r--users/fcuny/desktop/sway/wofi.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/fcuny/desktop/sway/wofi.nix b/users/fcuny/desktop/sway/wofi.nix
new file mode 100644
index 0000000..6368a7a
--- /dev/null
+++ b/users/fcuny/desktop/sway/wofi.nix
@@ -0,0 +1,19 @@
+{ pkgs, config, ... }:
+
+{
+  home.packages = with pkgs; [
+    wofi
+  ];
+
+  xdg.configFile."wofi/config".text = ''
+    image_size=48
+    columns=3
+    allow_images=true
+    insensitive=true
+    term=${config.wayland.windowManager.sway.config.terminal}
+
+    run-always_parse_args=true
+    run-cache_file=/dev/null
+    run-exec_search=true
+  '';
+}