about summary refs log tree commit diff
path: root/users/fcuny/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-03 15:12:16 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-03 15:12:16 -0700
commitb72274ab06b4c160fc8d3afe8e2d67863c893a58 (patch)
treeb00c3b128d55d1f51395243902c0dea60fe7df4b /users/fcuny/default.nix
parentRevert "create a new role for navidrome" (diff)
downloadworld-b72274ab06b4c160fc8d3afe8e2d67863c893a58.tar.gz
home-manager: add `isTrusted`
Install and configure some programs only on trusted machines. On trusted
machines, my mails, GPG and a few other things are configured. A machine
where this is not needed on a regular basis to get things done don't
need that much information.

Also rename `desktop/trust` to `trusted`, in case we want these packages
on a host that is not a desktop, and `trusted` is a better description.
Diffstat (limited to 'users/fcuny/default.nix')
-rw-r--r--users/fcuny/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/users/fcuny/default.nix b/users/fcuny/default.nix
index 32145dd..cf70f50 100644
--- a/users/fcuny/default.nix
+++ b/users/fcuny/default.nix
@@ -1,7 +1,8 @@
-{ config, lib, pkgs, isDesktop, ... }:
+{ config, lib, pkgs, isDesktop, isTrusted, ... }:
 
 {
-  imports = [ ./cli ./devel ] ++ (if isDesktop then [ ./desktop ] else [ ]);
+  imports = [ ./cli ./devel ] ++ (if isDesktop then [ ./desktop ] else [ ])
+    ++ (if isTrusted then [ ./trusted ] else [ ]);
 
   programs.home-manager.enable = true;