about summary refs log tree commit diff
path: root/users/fcuny/cli/media.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-08 17:02:16 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-08 17:02:16 -0700
commitb3d49dcb70a67c7fc60bfff9914bf0434e2b6390 (patch)
treeceed15cca5f2d63fbb293f312a40349549d8bc30 /users/fcuny/cli/media.nix
parentdelete all devel modules (diff)
downloadworld-b3d49dcb70a67c7fc60bfff9914bf0434e2b6390.tar.gz
delete all CLI modules
Everything is under home/ now
Diffstat (limited to 'users/fcuny/cli/media.nix')
-rw-r--r--users/fcuny/cli/media.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/users/fcuny/cli/media.nix b/users/fcuny/cli/media.nix
deleted file mode 100644
index 9e965e5..0000000
--- a/users/fcuny/cli/media.nix
+++ /dev/null
@@ -1,53 +0,0 @@
-{ config, lib, pkgs, hostname, ... }:
-let
-  musicDirectory = if (hostname == "tahoe") then
-    "/data/fast/music"
-  else
-    "/home/fcuny/media/music";
-in {
-  xdg.configFile."yt-dlp/config".source = ../configs/yt-dlp/config;
-
-  home.packages = with pkgs; [
-    yt-dlp
-    flac
-    abcde
-    (pkgs.writers.writeDashBin "rip-flac" ''
-      ${pkgs.abcde}/bin/abcde -Vx -G -a "cddb,read,encode,tag,move,clean" -o flac
-    '')
-  ];
-
-  # inspired from https://blog.yossarian.net/2022/02/21/Enjoying-music-curation-again
-  programs.beets = {
-    enable = true;
-    settings = {
-      directory = musicDirectory;
-      plugins =
-        "fromfilename discogs duplicates fetchart embedart badfiles lastgenre scrub";
-      paths = {
-        default = "$albumartist/$album%aunique{}/$track $title";
-        singleton = "Singles/$artist/$title";
-        comp = "Compilations/$album%aunique{}/$track - $title";
-        "albumtype:soundtrack" = "Soundtracks/$album ($year)/$track $title";
-      };
-      import = {
-        copy = true;
-        move = true;
-      };
-      va_name = "Various Artists";
-      embedart = { ifempty = true; };
-
-      lastgenre = {
-        auto = false;
-        canonical = true;
-        fallback = "unknown";
-        force = true;
-        prefer_specific = true;
-      };
-
-      fetchart = {
-        cautious = true;
-        sources = "filesystem coverart itunes amazon lastfm wikipedia";
-      };
-    };
-  };
-}