about summary refs log tree commit diff
path: root/tools/sendsms/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
commit2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f (patch)
tree6dd3fd5db0519e5fdb5e04fd329de16e49dfdd30 /tools/sendsms/default.nix
parentfix(flake): call some programs with `nix run .#tools.<name>` (diff)
downloadworld-2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f.tar.gz
feat(naersk): use naersk to build packages with rust
naersk makes it simple to build rust project in nix.

For this to work, `mkSystem` and `mkHomeManagerConfiguration` needs to
pass naersk to  my overlays.

I dropped the support to run the tools with `nix run .#tools...`: I
don't use this in practice and it's not making things simpler.

I dropped `nix-linter` from the check, it's reporting many errors
without helping me to fix them.
Diffstat (limited to 'tools/sendsms/default.nix')
-rw-r--r--tools/sendsms/default.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/sendsms/default.nix b/tools/sendsms/default.nix
index 6c9b79c..17c6b5a 100644
--- a/tools/sendsms/default.nix
+++ b/tools/sendsms/default.nix
@@ -1,6 +1,6 @@
 { pkgs, naersk, ... }:
 
-naersk.lib."${pkgs.system}".buildPackage {
+naersk.buildPackage {
   src = builtins.filterSource
     (path: type:
       type != "directory" || builtins.baseNameOf path != "target")
@@ -11,5 +11,4 @@ naersk.lib."${pkgs.system}".buildPackage {
 
   remapPathPrefix = true;
   doCheck = true;
-  copyLibs = true;
 }