about summary refs log tree commit diff
path: root/tools/govanity/flake.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-05-11 18:45:05 -0700
committerFranck Cuny <franck@fcuny.net>2022-05-11 18:46:55 -0700
commitec02496f673820244fabb3fadc903d1315218497 (patch)
treec7b7cc612d8303aec7d1fe5f093dc30a0d1f6bcb /tools/govanity/flake.nix
parentDockerfile: update steps (diff)
downloadworld-ec02496f673820244fabb3fadc903d1315218497.tar.gz
scripts: add a script to deploy
Remove the target from the Makefile, add a target to the flake
configuration.
Diffstat (limited to 'tools/govanity/flake.nix')
-rw-r--r--tools/govanity/flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/govanity/flake.nix b/tools/govanity/flake.nix
index 15b13d0..d2c2254 100644
--- a/tools/govanity/flake.nix
+++ b/tools/govanity/flake.nix
@@ -21,6 +21,16 @@
           nativeBuildInputs = with pkgs; [ go ];
         };
 
+        apps = {
+          deploy = pkgs.pkgs.writeShellScriptBin "run-deploy" ''
+            set -euxo pipefail
+            export PATH=${
+              pkgs.lib.makeBinPath [ pkgs.go pkgs.git pkgs.jq pkgs.flyctl ]
+            }:$PATH
+            bash ./scripts/deploy.sh
+          '';
+        };
+
         devShell = with pkgs;
           mkShell { nativeBuildInputs = [ git go gopls golangci-lint bash ]; };
       });