about summary refs log tree commit diff
path: root/tools/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-26 17:50:41 -0700
commit2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f (patch)
tree6dd3fd5db0519e5fdb5e04fd329de16e49dfdd30 /tools/default.nix
parentfix(flake): call some programs with `nix run .#tools.<name>` (diff)
downloadworld-2a7b36213c1b8bc9e03466bd7b99fa96abfecd8f.tar.gz
feat(naersk): use naersk to build packages with rust
naersk makes it simple to build rust project in nix.

For this to work, `mkSystem` and `mkHomeManagerConfiguration` needs to
pass naersk to  my overlays.

I dropped the support to run the tools with `nix run .#tools...`: I
don't use this in practice and it's not making things simpler.

I dropped `nix-linter` from the check, it's reporting many errors
without helping me to fix them.
Diffstat (limited to 'tools/default.nix')
-rw-r--r--tools/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/default.nix b/tools/default.nix
index fc60a7e..9f6d273 100644
--- a/tools/default.nix
+++ b/tools/default.nix
@@ -10,4 +10,6 @@ pkgs.lib.makeScope pkgs.newScope (pkgs: {
   ipconverter = pkgs.callPackage ./ipconverter { };
 
   git-blame-stats = pkgs.callPackage ./git-blame-stats { };
+
+  sendsms = pkgs.callPackage ./sendsms { };
 })