about summary refs log tree commit diff
path: root/secrets.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-06 08:09:06 -0800
committerFranck Cuny <franck@fcuny.net>2022-03-06 08:09:06 -0800
commit86a82a5e4eaf1db45e72182e8dc14ca85e9988cc (patch)
treed7160df4509c5227e2fd247e8e9f78cdb77bdbd5 /secrets.nix
parentbackups: unit to run maintenance on my backups (diff)
downloadworld-86a82a5e4eaf1db45e72182e8dc14ca85e9988cc.tar.gz
traefik: initial configuration
I want to run traefik on the NAS, so I can reach grafana and other
future services running on that host.

To manage TLS, we use let's encrypt with a DNS challenge. For this to
work we need a service account configuration, that is encrypted with
age.
Diffstat (limited to 'secrets.nix')
-rw-r--r--secrets.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/secrets.nix b/secrets.nix
index 64c60c0..3d50744 100644
--- a/secrets.nix
+++ b/secrets.nix
@@ -15,4 +15,7 @@ in {
 
   "secrets/network/tahoe/wireguard_privatekey.age".publicKeys =
     [ fcuny_aptos aptos tahoe ];
+
+  "secrets/traefik/gcp_service_account.json.age".publicKeys =
+    [ fcuny_aptos aptos tahoe ];
 }