about summary refs log tree commit diff
path: root/secrets.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-03-11 19:31:26 -0800
committerFranck Cuny <franck@fcuny.net>2022-03-11 19:31:26 -0800
commit71288332e85f993628439cecfbaa6ee207d01f46 (patch)
treeabcf96411b8ecff3a12a4a4a39b708d9212dd9df /secrets.nix
parentwm: ensure element is assigned to space #4 (diff)
downloadworld-71288332e85f993628439cecfbaa6ee207d01f46.tar.gz
rclone: synchronize restic repo to GCS
Add a couple of secrets to store the configuration and the service
account, and add a timer to synchronize the restic repository to a GCS
bucket once a day.
Diffstat (limited to 'secrets.nix')
-rw-r--r--secrets.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/secrets.nix b/secrets.nix
index 7a45923..ae0efaf 100644
--- a/secrets.nix
+++ b/secrets.nix
@@ -22,4 +22,7 @@ in {
   "secrets/unifi/unifi-poller.age".publicKeys = [ fcuny_aptos aptos tahoe ];
 
   "secrets/restic/repo-systems.age".publicKeys = [ fcuny_aptos aptos tahoe ];
+  "secrets/rclone/config.ini.age".publicKeys = [ fcuny_aptos aptos tahoe ];
+  "secrets/rclone/gcs_service_account.json.age".publicKeys =
+    [ fcuny_aptos aptos tahoe ];
 }