about summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-05-04 13:27:23 -0700
committerFranck Cuny <franck@fcuny.net>2024-05-04 13:28:46 -0700
commit4a86b5122c3c1bfcf442a59287da809248406526 (patch)
tree4ab5ec2af31159284c36765a54981fd2ceb28991 /pyproject.toml
parentadd a comment to set environment variables (diff)
downloadworld-4a86b5122c3c1bfcf442a59287da809248406526.tar.gz
start the conversion to python
Add support to move all the tools to python and organize them in a way
that should be simple.

I'm using https://rye-up.com for this.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml67
1 files changed, 67 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..7783aab
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,67 @@
+[project]
+name = "world"
+version = "0.1.0"
+description = "collection of tools and scripts"
+authors = [{ name = "Franck Cuny", email = "franck@fcuny.net" }]
+dependencies = [
+  "bs4>=0.0.2",
+  "requests>=2.31.0",
+  "prettytable>=3.10.0",
+  "termcolor>=2.4.0",
+]
+readme = "README.md"
+requires-python = ">= 3.8"
+
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[tool.rye]
+managed = true
+dev-dependencies = [
+  "python-lsp-server[all]>=1.11.0",
+  "python-lsp-ruff>=2.2.1",
+  "types-requests>=2.31.0.20240406",
+]
+
+[tool.hatch.metadata]
+allow-direct-references = true
+
+[tool.hatch.build.targets.wheel]
+packages = ["src/cli", "src/rbx_nomad"]
+
+[tool.ruff]
+line-length = 120
+
+[tool.ruff.format]
+docstring-code-format = true
+
+[tool.ruff.lint]
+select = [
+  # isort
+  "I",
+  # bugbear rules
+  "B",
+  # remove unused imports
+  "F401",
+  # bare except statements
+  "E722",
+  # unused arguments
+  "ARG",
+  # misuse of typing.TYPE_CHECKING
+  "TCH004",
+  # import rules
+  "TID251",
+]
+
+[tool.ruff.lint.pycodestyle]
+max-line-length = 120
+
+[tool.ruff.lint.isort]
+length-sort = true
+length-sort-straight = true
+combine-as-imports = true
+known-first-party = ["rbx_nomad"]
+
+[project.scripts]
+pizza = "cli.pizza:main"