about summary refs log tree commit diff
path: root/profiles/workstation.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-06 11:14:22 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-06 11:14:22 -0700
commitff2547f3ed61308614ad1fe832a6ea741a12b6f9 (patch)
treed8d9b086dfb67039795d640e349d017f79c7a9ce /profiles/workstation.nix
parentprofiles/gtk: configure dark mode properly (diff)
downloadworld-ff2547f3ed61308614ad1fe832a6ea741a12b6f9.tar.gz
profiles/workstation: move sway to the workstation profile
Diffstat (limited to 'profiles/workstation.nix')
-rw-r--r--profiles/workstation.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/profiles/workstation.nix b/profiles/workstation.nix
index 3b422a6..7ed2a3f 100644
--- a/profiles/workstation.nix
+++ b/profiles/workstation.nix
@@ -87,4 +87,27 @@
   # Use systemd-resolved
   services.resolved.enable = true;
   services.resolved.dnssec = "false";
+
+  xdg.portal = {
+    enable = true;
+    wlr.enable = true;
+    extraPortals =
+      [ pkgs.xdg-desktop-portal-gtk pkgs.xdg-desktop-portal-wlr ];
+  };
+
+  programs.sway = {
+    enable = true;
+    wrapperFeatures.gtk = true;
+    extraPackages = with pkgs; [
+      brightnessctl
+      polkit_gnome
+      xsettingsd
+      swaylock
+      swayidle
+      wl-clipboard
+    ];
+    extraSessionCommands = ''
+      export MOZ_ENABLE_WAYLAND=1
+    '';
+  };
 }