about summary refs log tree commit diff
path: root/profiles/workstation.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-05-02 07:55:03 -0700
committerFranck Cuny <franck@fcuny.net>2023-05-02 07:55:03 -0700
commit9ee5eb9892fd25bfba8fbff26c68a0804e23abf9 (patch)
tree43609d7caa5c6c4a36722c30ef84811a884a5759 /profiles/workstation.nix
parentprofiles: create default and server (diff)
downloadworld-9ee5eb9892fd25bfba8fbff26c68a0804e23abf9.tar.gz
profiles/workstation: add font configurations
Diffstat (limited to 'profiles/workstation.nix')
-rw-r--r--profiles/workstation.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/profiles/workstation.nix b/profiles/workstation.nix
index fc888d3..2c7ee02 100644
--- a/profiles/workstation.nix
+++ b/profiles/workstation.nix
@@ -42,6 +42,37 @@
 
   hardware.pulseaudio.enable = false;
 
+  fonts = {
+    enableDefaultFonts = true;
+    fontDir.enable = true;
+    fontconfig = {
+      enable = true;
+      defaultFonts = {
+        serif = [ "Bitstream Vera Serif" ];
+        sansSerif = [ "Bitstream Vera Sans" ];
+        monospace = [ "Bitstream Vera Sans Mono" ];
+      };
+    };
+    fonts = with pkgs; [
+      dejavu_fonts
+      ttf_bitstream_vera
+
+      font-awesome_5
+
+      noto-fonts
+      noto-fonts-cjk # Chinese, Japanese, Korean
+      noto-fonts-emoji
+      noto-fonts-emoji
+      noto-fonts-extra
+
+      cantarell-fonts
+
+      source-code-pro
+      source-sans-pro
+      source-serif-pro
+    ];
+  };
+
   # Misc packages useful on a workstation
   environment.systemPackages = with pkgs; [
     # sound related