about summary refs log tree commit diff
path: root/packages/pizza/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-04-28 19:15:51 -0700
committerFranck Cuny <franck@fcuny.net>2024-04-28 19:17:12 -0700
commit58d0a9cb616e35daf115b8e1aa9f5b79e4a21a70 (patch)
tree87f0cb04b860048f70c2f90cf9ba9d7d5e7f2634 /packages/pizza/default.nix
parentchore: update flake (diff)
downloadworld-58d0a9cb616e35daf115b8e1aa9f5b79e4a21a70.tar.gz
add a script to fetch cheeseboard's menu
Delete the version in go.
Diffstat (limited to 'packages/pizza/default.nix')
-rw-r--r--packages/pizza/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/pizza/default.nix b/packages/pizza/default.nix
new file mode 100644
index 0000000..cf5e836
--- /dev/null
+++ b/packages/pizza/default.nix
@@ -0,0 +1,31 @@
+{ lib, python3 }:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "pizza";
+  src = ./pizza.py;
+  version = "0.1.0";
+  format = "other";
+
+  buildInputs = [ python3 ];
+  propagatedBuildInputs = with python3.pkgs; [
+    beautifulsoup4
+    prettytable
+    requests
+    termcolor
+  ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "Get the pizza for the week for CheeseBoard.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}