about summary refs log tree commit diff
path: root/packages/hashi
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-18 09:05:00 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-18 09:05:35 -0800
commit062e241e425f3457019a44e88f7664c10ed50ff4 (patch)
tree5f10e0252eea2c75639b09ca17eb3c0fa42f981d /packages/hashi
parentinstall some tools only on work machine (diff)
downloadworld-062e241e425f3457019a44e88f7664c10ed50ff4.tar.gz
add overlay for the hashi tool
Diffstat (limited to 'packages/hashi')
-rw-r--r--packages/hashi/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/hashi/default.nix b/packages/hashi/default.nix
new file mode 100644
index 0000000..54f71d1
--- /dev/null
+++ b/packages/hashi/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchurl, lib, ... }:
+let
+  url =
+    "https://artifactory.rbx.com:443/artifactory/generic-rbx-local/hashi/0.1.4/bin/hashi_darwin-amd64";
+in
+stdenv.mkDerivation rec {
+  pname = "hashi";
+  version = "0.1.4";
+  src = builtins.trace "Attempting to fetch: ${url}" fetchurl {
+    inherit url;
+    sha256 = "sha256-uX6AdOUfh6JEwS20kQwjp9Os12lVOGoCajOV9sYWXtA=";
+  };
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/hashi
+    chmod +x $out/bin/hashi
+  '';
+
+  dontUnpack = true;
+  dontStrip = true;
+  doInstallCheck = true;
+
+  installCheckPhase = ''
+    $out/bin/hashi -e sitetest3 version
+  '';
+
+  meta = with lib; {
+    description = "hashi command-line tool";
+    homepage = "http://go/hashicli";
+    license = licenses.unfree;
+    platforms = [ "x86_64-darwin" ];
+  };
+}
+