about summary refs log tree commit diff
path: root/ops/ci/shellcheck.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-07-26 17:45:49 -0700
committerFranck Cuny <franck@fcuny.net>2022-08-06 13:01:15 -0700
commitb42879a95377b4b10f12855d831eb58857b60d2e (patch)
tree61676d392a6e536bd0eb44d13a18914c3374badb /ops/ci/shellcheck.nix
parentmeta(flake): bump dependencies (diff)
downloadworld-b42879a95377b4b10f12855d831eb58857b60d2e.tar.gz
ref(ci): delete custom scripts for formatting
Since I have configured the pre-commit hooks, I can use them instead of
my custom scripts: less things to maintain and easier to read output.

Change-Id: Ic833ec88ed9fbcbe52b1b1680f978da3a5a08b31
Reviewed-on: https://cl.fcuny.net/c/world/+/681
Tested-by: CI
Reviewed-by: Franck Cuny <franck@fcuny.net>
Diffstat (limited to 'ops/ci/shellcheck.nix')
-rw-r--r--ops/ci/shellcheck.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/ops/ci/shellcheck.nix b/ops/ci/shellcheck.nix
deleted file mode 100644
index c862a87..0000000
--- a/ops/ci/shellcheck.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ pkgs, ... }: rec {
-  mkShellCheckScript = src:
-    let
-      script = pkgs.writeScript "shellcheck" ''
-        EXIT_STATUS=0
-        while IFS= read -r -d ''' i
-        do
-          if ${pkgs.shellcheck}/bin/shellcheck -x "$i"
-          then
-            echo "$i [ PASSED ]"
-          else
-            echo "$i [ FAILED ]"
-            EXIT_STATUS=$(($EXIT_STATUS+1))
-          fi
-        done <  <(find -name '*.sh' -print0)
-        echo Total Failed Files: $EXIT_STATUS
-        exit "$EXIT_STATUS"
-      '';
-    in
-    {
-      type = "app";
-      program = "${script}";
-    };
-}