about summary refs log tree commit diff
path: root/nix/users/fcuny/work.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-18 09:05:00 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-18 09:05:35 -0800
commit062e241e425f3457019a44e88f7664c10ed50ff4 (patch)
tree5f10e0252eea2c75639b09ca17eb3c0fa42f981d /nix/users/fcuny/work.nix
parentinstall some tools only on work machine (diff)
downloadworld-062e241e425f3457019a44e88f7664c10ed50ff4.tar.gz
add overlay for the hashi tool
Diffstat (limited to 'nix/users/fcuny/work.nix')
-rw-r--r--nix/users/fcuny/work.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nix/users/fcuny/work.nix b/nix/users/fcuny/work.nix
index cc80104..20c49c4 100644
--- a/nix/users/fcuny/work.nix
+++ b/nix/users/fcuny/work.nix
@@ -9,5 +9,15 @@
 
     # for ssh
     sapi
+
+    # for tokens
+    hashi
   ];
+
+  programs.fish = {
+    shellAbbrs = {
+      "ssh-sign-chi" =
+        "${pkgs.hashi}/bin/hashi -e chi1 sign --key=/Users/fcuny/.ssh/id_ed25519.pub key";
+    };
+  };
 }