about summary refs log tree commit diff
path: root/nix/users/fcuny/go.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-16 09:25:23 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-16 09:25:23 -0800
commit1bbd4e19c5595e6a6c310bd36fac5b4bd97ff39f (patch)
treee5ec852d0aa9378a5fae766f70d4c133acd5f8d1 /nix/users/fcuny/go.nix
parentmove gitotlite to vm-synology (diff)
downloadworld-1bbd4e19c5595e6a6c310bd36fac5b4bd97ff39f.tar.gz
refactor home-manager
Only install what's needed for specific OSes.
Diffstat (limited to 'nix/users/fcuny/go.nix')
-rw-r--r--nix/users/fcuny/go.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nix/users/fcuny/go.nix b/nix/users/fcuny/go.nix
new file mode 100644
index 0000000..b52f89e
--- /dev/null
+++ b/nix/users/fcuny/go.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }: {
+  home.packages = with pkgs; [ go-tools golangci-lint gopls delve ];
+
+  programs.go = {
+    enable = true;
+    goPath = ".local/share/pkg.go";
+    goBin = ".local/bin.go";
+    goPrivate = [ "github.rbx.com/*" "github.com/fcuny/*" "git.fcuny.net/*" ];
+  };
+
+  home.sessionPath = [ config.home.sessionVariables.GOBIN ];
+}