about summary refs log tree commit diff
path: root/nix/profiles/home-manager/work.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-03-07 10:07:49 -0800
committerFranck Cuny <franck@fcuny.net>2024-03-07 10:10:55 -0800
commit318978655894aaa82fdf4c5de1eb9c58cb351a91 (patch)
treec96d22c7f116fcf9c9ee56dd2c222f432540b0f5 /nix/profiles/home-manager/work.nix
parentinstall seqstat on the work profile (diff)
downloadworld-318978655894aaa82fdf4c5de1eb9c58cb351a91.tar.gz
share configuration for shell utils
Diffstat (limited to 'nix/profiles/home-manager/work.nix')
-rw-r--r--nix/profiles/home-manager/work.nix46
1 files changed, 2 insertions, 44 deletions
diff --git a/nix/profiles/home-manager/work.nix b/nix/profiles/home-manager/work.nix
index 4933865..a9800cd 100644
--- a/nix/profiles/home-manager/work.nix
+++ b/nix/profiles/home-manager/work.nix
@@ -1,4 +1,4 @@
-{ self, pkgs, ... }: {
+{ ... }: {
 
   home.stateVersion = "23.05";
 
@@ -6,6 +6,7 @@
     ./dev.nix
     ./firefox.nix
     ./git.nix
+    ./shell.nix
     ./ssh.nix
     ./zsh.nix
   ];
@@ -13,47 +14,4 @@
   programs.git = {
     userEmail = "fcuny@roblox.com";
   };
-
-  home.packages = with pkgs; [
-    # general shell utils
-    direnv
-    ripgrep
-    tree
-    wget
-
-    # data manipulation
-    jless
-    jq
-    yq
-
-    # nix related
-    nil
-    nix-direnv
-    nixd
-    nixfmt
-    nixpkgs-fmt
-    rnix-lsp
-
-    self.packages.${pkgs.system}.seqstat
-  ];
-
-  home.sessionVariables = {
-    EDITOR = "emacsclient -a=";
-    VISUAL = "emacsclient -a=";
-    LESS = "-FRSXM";
-    LESSCHARSET = "utf-8";
-    PAGER = "less";
-  };
-
-  programs = {
-    direnv = {
-      enable = true;
-      nix-direnv.enable = true;
-      enableZshIntegration = true;
-      config = {
-        global.disable_stdin = true;
-        global.strict_env = true;
-      };
-    };
-  };
 }