about summary refs log tree commit diff
path: root/nix/mkSystem.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2023-03-27 17:49:49 -0700
committerFranck Cuny <franck@fcuny.net>2023-03-27 19:11:25 -0700
commita35050d9bc640309a8216b520a9b0350266de74f (patch)
tree5afb8a74db49cd2566fdb9311d1bdff1ab0b00d3 /nix/mkSystem.nix
parentmodules/console: fix syntax (diff)
downloadworld-a35050d9bc640309a8216b520a9b0350266de74f.tar.gz
modules/sendsms: gate the unit with a file
To prevent the unit to be triggered multiple times if the host has
already rebooted, we create a gate file when we're done running, and
before running, we check if the file exists.

Enable the service on tahoe.

Don't restart the unit when its definition has changed.
Diffstat (limited to 'nix/mkSystem.nix')
-rw-r--r--nix/mkSystem.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nix/mkSystem.nix b/nix/mkSystem.nix
index 4debbab..1cb450f 100644
--- a/nix/mkSystem.nix
+++ b/nix/mkSystem.nix
@@ -17,6 +17,7 @@ inputs.nixpkgs.lib.nixosSystem {
         overlays = [
           inputs.nur.overlay
           inputs.rust.overlays.default
+          inputs.sendsms.overlay
           (final: prev:
             {
               tools = import "${self}/tools" { pkgs = prev; inherit naersk; };