about summary refs log tree commit diff
path: root/nix/lib/mkSystem.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
committerFranck Cuny <franck@fcuny.net>2024-12-19 12:54:16 -0800
commitbc40b7e0ad2ef5960b7f1695b4520909252a0e49 (patch)
treef22e9e5001720bbc82055a5d4d3b24077b9647de /nix/lib/mkSystem.nix
parentuse treefmt to format all the files (diff)
downloadworld-bc40b7e0ad2ef5960b7f1695b4520909252a0e49.tar.gz
switch to the newer version of nixfmt
`nixfmt-rfc-style' replaces `nixfmt-classic'. It's actively
maintained, but also changes the style, so this commit touches all the
files in the repository.
Diffstat (limited to 'nix/lib/mkSystem.nix')
-rw-r--r--nix/lib/mkSystem.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/nix/lib/mkSystem.nix b/nix/lib/mkSystem.nix
index c9c8074..b54a4f4 100644
--- a/nix/lib/mkSystem.nix
+++ b/nix/lib/mkSystem.nix
@@ -3,7 +3,11 @@
 { nixpkgs, inputs }:
 
 name:
-{ system, user, darwin ? false, }:
+{
+  system,
+  user,
+  darwin ? false,
+}:
 
 let
   # The config files for this system.
@@ -12,13 +16,11 @@ let
   userHMConfig = ../users/${user}/home-manager.nix;
 
   # NixOS vs nix-darwin functionst
-  systemFunc =
-    if darwin then inputs.darwin.lib.darwinSystem else nixpkgs.lib.nixosSystem;
-  home-manager = if darwin then
-    inputs.home-manager.darwinModules
-  else
-    inputs.home-manager.nixosModules;
-in systemFunc rec {
+  systemFunc = if darwin then inputs.darwin.lib.darwinSystem else nixpkgs.lib.nixosSystem;
+  home-manager =
+    if darwin then inputs.home-manager.darwinModules else inputs.home-manager.nixosModules;
+in
+systemFunc rec {
   inherit system;
 
   modules = [