about summary refs log tree commit diff
path: root/nix/hosts/nixos/wildcat/networking.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2024-11-17 11:16:44 -0800
committerFranck Cuny <franck@fcuny.net>2024-11-17 11:16:44 -0800
commit357fbda2bb2400a52f8dec61b66342b92fa945ae (patch)
treeb81c4ea017372f086963094903a01ac5e56a98ef /nix/hosts/nixos/wildcat/networking.nix
parentinstall font dejavu (diff)
downloadworld-357fbda2bb2400a52f8dec61b66342b92fa945ae.tar.gz
move machine configurations under darwin and nixos
Don't manage fonts on Darwin with homebrew.
Diffstat (limited to 'nix/hosts/nixos/wildcat/networking.nix')
-rw-r--r--nix/hosts/nixos/wildcat/networking.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/nix/hosts/nixos/wildcat/networking.nix b/nix/hosts/nixos/wildcat/networking.nix
new file mode 100644
index 0000000..c0b4bd0
--- /dev/null
+++ b/nix/hosts/nixos/wildcat/networking.nix
@@ -0,0 +1,51 @@
+{ lib, ... }: {
+  # This file was populated at runtime with the networking
+  # details gathered from the active system.
+  networking = {
+    nameservers =
+      [ "2a01:4ff:ff00::add:2" "2a01:4ff:ff00::add:1" "185.12.64.1" ];
+    defaultGateway = "172.31.1.1";
+    defaultGateway6 = {
+      address = "fe80::1";
+      interface = "eth0";
+    };
+    dhcpcd.enable = false;
+    usePredictableInterfaceNames = lib.mkForce false;
+    interfaces = {
+      eth0 = {
+        ipv4.addresses = [{
+          address = "5.78.87.68";
+          prefixLength = 32;
+        }];
+        ipv6.addresses = [
+          {
+            address = "2a01:4ff:1f0:d1a3::1";
+            prefixLength = 64;
+          }
+          {
+            address = "fe80::9400:3ff:fe98:d6dc";
+            prefixLength = 64;
+          }
+        ];
+        ipv4.routes = [{
+          address = "172.31.1.1";
+          prefixLength = 32;
+        }];
+        ipv6.routes = [{
+          address = "fe80::1";
+          prefixLength = 128;
+        }];
+      };
+
+    };
+    firewall.allowedTCPPorts = [
+      22 # ssh
+      80 # nginx
+      443 # nginx
+    ];
+  };
+  services.udev.extraRules = ''
+    ATTR{address}=="96:00:03:98:d6:dc", NAME="eth0"
+
+  '';
+}